Download a Supported Browser

Provider Portal is built on advanced modern technologies and does not support old browsers. It is strongly recommended that you use a supported browser to minimize potential security risks and ensure that you have the best possible portal experience. If you use an unsupported browser, some portal features may not work properly. Supported browsers are dependent on device and operating system. See the System Requirements topic for more information. 

Note: Provider Portal does not support functions provided by your browser context menu such as print, select all, and copy.

Supported Browsers

- Apple Safari 
Google Chrome
Microsoft Edge
Mozilla Firefox

Apple Safari

Provider Portal supports Apple Safari browser on Apple devices only. You can keep Safari up to date by keeping macOS and iOS up to date.

Google Chrome

Download Chrome

Microsoft Edge

Download Microsoft Edge 

Mozilla Firefox

Download Firefox

Copyright Cerner Corporation. All rights reserved.